Supported drivers

The following drivers are supported for FQL.

See the applicable repository README page for instructions on how to install and use the driver.

Visit Fauna forums to request features or support for other languages.

JavaScript driver

Version

1.3.1

Repository

Supported runtimes

Browsers, stable versions of:

  • Chrome

  • Firefox

  • Safari

  • Edge

Node.js Current and Active LTS:

  • Current: v19

  • Active LTS: v18

Other:

  • Cloudflare Workers

  • AWS Lambda

  • Netlify Functions

  • Vercel Functions

Report issues:

Python driver

Version

1.1.2

Repository

Python Package Index (PyPI)

Supported Python versions

Python 3.9
Python 3.10
Python 3.11

Supported runtimes

Other:

  • AWS Lambda

  • Vercel Functions

Report issues:

Go driver

Version

1.1.1

Repository

Go Package

Supported Go versions

go1.19
go1.20

Supported runtimes

Other:

  • AWS Lambda

  • Netlify Functions

  • Vercel Functions

Report issues:

.NET (C#) driver

Version

0.1.0-beta

Supported .NET versions

8, 7.x, 6.x

Supported runtimes

Other:

  • Azure Functions

Repository

Report issues:

Is this article helpful? 

Tell Fauna how the article can be improved:
Visit Fauna's forums or email docs@fauna.com

Thank you for your feedback!